Page 3 of 3

Re: widget v3

Posted: Sun May 14, 2017 11:37 am
by KungFuChe
UPDATE: a cable fault was determined to be the cause of hang at splash screen (need to trap PHY errors)

Also noticed some state corruption related to suspend/resume. Observed the following issues:

- widget appears in tray but connection is not routed through VPN
- widget disappears from tray but VPN connnection still active
- widget crashes on exit request and clearnet connectivity is not restored (but can reconnect to VPN if widget is relaunched)

+ Suggest testing for OS/CPU compatibility

(example: dont install latest TAP driver on XP/POSready, dont install binaries with SSE2 instructions on unsupported CPU)

PS - forum says you can edit your posts but edit button does not appear at the next login

Re: widget v3

Posted: Mon Jun 05, 2017 12:17 am
by rwilcher
I have been running v3 for 3 days now. Have seen no instability
under Windows 10. Works like a champ so far.

Re: widget v3

Posted: Mon Jun 19, 2017 12:41 am
by df
Just built a new widget v3.0.0.72 that includes code that now saves that connect timeout value (Under "Options" -> "Connecting") so it's remembered on restart.

Also OpenVPN/OpenSSL binaries/libraries upgraded to 2.3.16/1.0.2l.

Latest hashes for https://cryptostorm.is/cryptostorm_setup.exe -
crc32: 6fe993a6
md4: 2c09931daadb7ac8e88401422364c0ea
md5: 47a1d8d88fbe1c9b8655669af25f65a9
ripemd160: 0d233cd5f3c4842c772df06f2ebb4d42eccf93d0
sha1: b87c4cf014e70b8eabb462d2330388f9f87ce4a8
sha256: f9cabb029ea14a30feff44a33ed2ec8b73f9508d5840eb0bb495b7ab6bf4e083
sha384: ded51f638c8cef40a9a2ea268360d90ef213e6bf049a5aa5e427f027bc867ea2e65e767a332d9a564110b168903bab00
sha512: 3b6f4e4c14880f77dd980edcd9bbb414d83ed183a8dce91c9801858d6cedc53ceea1acb39bb567fa4f0b0e8ae3aded3f03858790d6efdd3805a7a9f687a828e0
wpool512: e407fe382d3f31d3189b0f237feb41a6541e7be1e5f1dfbfa75d6baedeae1ff815af2d32f2a3a8f6b5c16ddee18926443a5364e0d096150682bf9c1179aa4342


@KungFuChe
XP is no longer supported. Anyone still on XP will have to stay on the older v2.22, which won't receive any new updates, unless some horribly vulnerable issue is discovered in the openvpn/openssl that version uses.
It's usually a bad idea to provide backwards compatibility for an OS version that stopped receiving security updates several years ago.
I do plan on doing more tests regarding the different ways internet can be disconnected and how to detect it so the widget responds accordingly.
Same goes for the different CPU features and architectures, and the systray issues that seem to vary by Windows version.

Re: widget v3

Posted: Wed Jun 21, 2017 5:22 pm
by rwilcher
What is the correct v3 widget I should get ? Confusing.

Re: widget v3

Posted: Thu Jun 22, 2017 12:20 am
by df
@rwilcher
The latest one is always at https://cryptostorm.is/cryptostorm_setup.exe

Re: widget v3

Posted: Sat Jun 24, 2017 5:30 am
by rwilcher
Thank you very much.

Re: widget v3

Posted: Mon Jul 17, 2017 11:55 pm
by ATurtle
Glad to see that XP is finally being killed off by providers!

Re: widget v3

Posted: Tue Jul 18, 2017 12:45 am
by df
@ATurtle
If anyone is still using XP, they clearly don't care about security.
You could argue that Microsoft updates doesn't equate to security (which is accurate), but since XP hasn't received security patches for several years now, using it under any pretense is just plain dumb.
Maybe in a system/VM that's offline, or behind such a restrictive firewall that nothing's possible... but then what's the point?

Re: widget v3

Posted: Sat Aug 12, 2017 4:36 pm
by JTD121
So just looking for an update, and it looks like I can't upgrade the client? Even running as admin on Windows 8.1 gives me the following error:

Image

Of course, watching that file, it gets created, and what looks like a temp file, and then this error pops up. So something is trying to change the client.exe before this happens.

Any ideas?

Re: widget v3

Posted: Sat Aug 12, 2017 5:37 pm
by df
@JTD121
Do you get that error when running cryptostorm_setup.exe? If so, you should exit the widget before you begin the installation. Windows can't overwrite client.exe if it's already running. Although, the installation should detect if the widget is already running and ask if it's okay to close it before attempting to overwrite it.

Re: widget v3

Posted: Mon Aug 14, 2017 5:40 am
by JTD121
@df, Y'know, I don't know what the issue was, but I restarted this specific laptop and just tried again, and it worked without a hitch.

Previously I made sure the client.exe and csvpn EXEs weren't running, so maybe it was pending OS updates?

Since we're on the subject, any updates past 3.0.0.72?

Re: widget v3

Posted: Fri Sep 29, 2017 3:34 pm
by vaiybora
Thank for the good topic,Thanks for your sharing.

โคนัน

Image