Ξ welcome to cryptostorm's member forums ~ you don't have to be a cryptostorm member to post here Ξ
Ξ any OpenVPN configs found on the forum are likely outdated. For the latest, visit here or GitHub Ξ
Ξ If you're looking for tutorials/guides, check out the new https://cryptostorm.is/#section6 Ξ

Hashed Token Not Working

Looking for assistance with a cryptostorm connection issue? Post here & we'll help out. Also: if you're not sure where to post, do so here & we'll move things around as needed. Also: for quickest support, email our oddly calm & easygoing support reps at support@cryptostorm.is :)
User avatar

Topic Author
sottovoce
Posts: 18
Joined: Thu Feb 13, 2014 10:13 pm

Hashed Token Not Working

Postby sottovoce » Mon Mar 19, 2018 10:12 pm

I just got a new token. I hashed the token using your hash tool. I have tried this many times and it does not work. On the other hand, the unhashed token works just fine in all the openvpn network managers I have. I am not understanding this because for years all my hashed tokens worked fine. I even tried re-hashing it and got another sequence but that doesn't work either. Could anyone please explain what is going on? Is there any real danger using the unhashed token? Thank you very much for any info.

User avatar

parityboy
Site Admin
Posts: 1282
Joined: Wed Feb 05, 2014 3:47 am

Re: Hashed Token Not Working

Postby parityboy » Wed Mar 21, 2018 2:04 am

@OP

In reality there's no real danger using the un-hashed token, since if you use the un-hashed token the servers will recognise this and hash it before querying the database to authenticate you - the database only contains hashed representations of the tokens.

If you're using Linux you can do this in a terminal

Code: Select all

echo -n <token> | sha512sum -


:)


Return to “member support & tech assistance”

Who is online

Users browsing this forum: No registered users and 28 guests

cron

Login