Ξ welcome to cryptostorm's member forums ~ you don't have to be a cryptostorm member to post here Ξ
Ξ any OpenVPN configs found on the forum are likely outdated. For the latest, visit here or GitHub Ξ
Ξ If you're looking for tutorials/guides, check out the new https://cryptostorm.is/#section6 Ξ

iPhone VPN logon not working

Looking for assistance with a cryptostorm connection issue? Post here & we'll help out. Also: if you're not sure where to post, do so here & we'll move things around as needed. Also: for quickest support, email our oddly calm & easygoing support reps at support@cryptostorm.is :)

Topic Author
Captain Blackberry
Posts: 22
Joined: Thu Oct 15, 2015 2:11 pm

iPhone VPN logon not working

Postby Captain Blackberry » Fri Jul 29, 2016 6:01 pm

In the past I've used cstorm successfully using the linux balancer profile with a multi-month long token without issue.

My token expired and I didn't use the VPN for a month or so on my iPhone.

I've since got a new token, and it all works fine on my desktop computer.

But I'm having trouble getting it working on my iPhone.


I have OVPN 1.0.7.

I created .ovpn files from text files and emailed them to my phone to import into OVPN.
I used the Github files from here:
https://github.com/cryptostorm/cryptost ... master/mac

Both dynamic and england.

Neither appears to log on. I've used the token for the username, and a random string for the password.

The connection (via the log) stops at the line IV_LZO=1 with Session invalidated: KEV_NEGOTIATE_ERROR

User avatar

Fermi
Site Admin
Posts: 226
Joined: Tue Jun 17, 2014 11:42 am

Re: iPhone VPN logon not working

Postby Fermi » Fri Jul 29, 2016 8:30 pm

Hi,

Please do the following:

Code: Select all

1) Go to iOS settings
2) Scroll down to the settings panel for OpenVPN
3) Look for "Force AES-CBC ciphersuites" in advanced settings
4) Enable it. It's off by default.


Regards,

/fermi


Topic Author
Captain Blackberry
Posts: 22
Joined: Thu Oct 15, 2015 2:11 pm

Re: iPhone VPN logon not working

Postby Captain Blackberry » Sat Aug 06, 2016 6:49 pm

Thanks Fermi.


bob8490

Re: iPhone VPN logon not working

Postby bob8490 » Tue Jan 23, 2018 8:53 pm

THANK YOU. I've been stuck on version 1.0.5 since forever and could never update because newer versions failed to connect to my server. After enabling "Force AES-CBC ciphersuites," it works perfectly.


Return to “member support & tech assistance”

Who is online

Users browsing this forum: Google [Bot] and 21 guests

Login