Ξ welcome to cryptostorm's member forums ~ you don't have to be a cryptostorm member to post here Ξ
∞ take a peek at our legendary cryptostorm_is twitter feed if you're into that kind of thing ∞
Ξ we're rolling out voodoo network security across cryptostorm - big things happening, indeed! Ξ
Ξ any OpenVPN configs found on the forum are likely outdated. For the latest, visit GitHub Ξ
Ξ We've updated our CA certificate. All members need to be using the latest ones by Dec 22. See this page for more infoΞ

"Stale" Sessions

Looking for assistance with a cryptostorm connection issue? Post here & we'll help out. Also: if you're not sure where to post, do so here & we'll move things around as needed. Also: for quickest support, email our oddly calm & easygoing support reps at support@cryptostorm.is :)
User avatar

Topic Author
parityboy
Site Admin
Posts: 1220
Joined: Wed Feb 05, 2014 3:47 am

"Stale" Sessions

Postby parityboy » Tue Apr 07, 2015 5:48 pm

Platform
My workstation is running Mint 17.1 KDE, with OpenVPN 2.3.2.

This is something I've noticed recently (mostly while connected to Turing). After a couple of days, the session seems to turn "stale", and the DNS resolvers become either unavailable or simply don't resolve anything, not even Google. My connection is intended to be up 24/7, since my computer is also up 24/7. Killing and then restarting the VPN session cures the problem.

Has anyone else experienced this?

User avatar

cryptostorm_support
ForumHelper
Posts: 296
Joined: Sat Jan 26, 2013 4:31 am
Contact:

Re: "Stale" Sessions

Postby cryptostorm_support » Wed Apr 08, 2015 11:52 pm

I haven't heard of this issue from anyone else, but I'll push it forward to the rest of the team. How recently has this started occurring?
cryptostorm_support shared support team forum account
PLEASE DON'T SEND PRIVATE MESSAGES with support questions!
--> feel free to use any of our other contact channels, or post in the support forum
cryptostorm: structurally anonymous, token-based, unlimited ☂ bandwidth, opensource, darknet data security for everyone!
keybase.io validatorsonename.io validatorsPGP key @ MITnetwork statuscryptostorm github
support team bitmessage address: BM-2cTMH8K5JnjbfSALjZtSkRWCLfc3Tr8GBV
support team email: support@cryptostorm.is
live chat support: #cryptostorm

User avatar

Topic Author
parityboy
Site Admin
Posts: 1220
Joined: Wed Feb 05, 2014 3:47 am

Re: "Stale" Sessions

Postby parityboy » Thu Apr 09, 2015 1:02 am

@support

I can't remember exactly, but is definitely been happening sporadically over the last four weeks. What I will say is that it only appears to be happening on Turing (I have a VM which spends most of its life connected to Cantus, but it does not appear to be suffering this issue).

The logs don't show anything untoward, and the VPN does not appear to disconnect. I'm now wondering if it's a bug in dnsmasq...the next time it happens I'll try to grab some pcaps.

User avatar

marzametal
Posts: 505
Joined: Mon Aug 05, 2013 11:39 am

Re: "Stale" Sessions

Postby marzametal » Sat Apr 11, 2015 6:55 am

I've had stale from time to time, but I blame that on the streaming assault posed by Netflix and the local 3 companies... killing our internet, they are...

User avatar

jlg
Posts: 92
Joined: Mon May 05, 2014 2:44 am

Re: "Stale" Sessions

Postby jlg » Tue Apr 21, 2015 10:57 am

I've had this problem. But usually after 10+ hours of being connected.


Return to “member support & tech assistance”

Who is online

Users browsing this forum: No registered users and 11 guests

Login