Ξ welcome to cryptostorm's member forums ~ you don't have to be a cryptostorm member to post here Ξ
∞ take a peek at our legendary cryptostorm_is twitter feed if you're into that kind of thing ∞
Ξ we're rolling out voodoo network security across cryptostorm - big things happening, indeed! Ξ
Ξ any OpenVPN configs found on the forum are likely outdated. For the latest, visit GitHub Ξ
Ξ We've updated our CA certificate. All members need to be using the latest ones by Dec 22. See this page for more infoΞ

Trouble Connecting To Portugal

Looking for assistance with a cryptostorm connection issue? Post here & we'll help out. Also: if you're not sure where to post, do so here & we'll move things around as needed. Also: for quickest support, email our oddly calm & easygoing support reps at support@cryptostorm.is :)
User avatar

Topic Author
parityboy
Site Admin
Posts: 1220
Joined: Wed Feb 05, 2014 3:47 am

Trouble Connecting To Portugal

Postby parityboy » Thu Oct 02, 2014 8:35 am

I made an entry for Brisa in my Network manager (Mint 14 KDE, OpenVPN 2.3.2). It fails to connect and this is what I get in the logs.

Code: Select all

Oct  2 04:27:30 vostok nm-openvpn[5450]: OpenVPN 2.3.2 x86_64-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [eurephia] [MH] [IPv6] built on Feb  4 2014
Oct  2 04:27:30 vostok nm-openvpn[5450]: WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Oct  2 04:27:30 vostok nm-openvpn[5450]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Oct  2 04:27:30 vostok nm-openvpn[5450]: UDPv4 link local: [undef]
Oct  2 04:27:30 vostok nm-openvpn[5450]: UDPv4 link remote: [AF_INET]94.46.8.229:443
Oct  2 04:28:11 vostok NetworkManager[882]: <warn> VPN connection 'Cryptostorm (Brisa, pH)' (IP Config Get) timeout exceeded.
Oct  2 04:28:11 vostok NetworkManager[882]: <info> Policy set 'Wired connection 1' (eth1) as default for IPv4 routing and DNS.
Oct  2 04:28:11 vostok nm-openvpn[5450]: SIGTERM[hard,] received, process exiting
Oct  2 04:28:16 vostok NetworkManager[882]: <info> VPN service 'openvpn' disappeared


I'm using the post-Heartbleed certificates and nodes; all of the other nodes connect perfectly well.

User avatar

Fermi
Site Admin
Posts: 225
Joined: Tue Jun 17, 2014 11:42 am

Re: Trouble Connecting To Portugal

Postby Fermi » Thu Oct 02, 2014 11:10 am

@parityboy,

https://cryptostorm.is/status indicates a timeout.
Problems were also mentioned in the IRC channel around the time you've posted this.
When brisa is up according to: https://cryptostorm.is/status , you should hopefully be able to connect.

Regards,

/Fermi


User avatar

Tealc
ForumHelper
Posts: 283
Joined: Tue Jan 28, 2014 12:38 am

Re: Trouble Connecting To Portugal

Postby Tealc » Thu Oct 02, 2014 10:01 pm

Down already?

Or actually giving it the last "touches"....


:D

User avatar

Tealc
ForumHelper
Posts: 283
Joined: Tue Jan 28, 2014 12:38 am

Re: Trouble Connecting To Portugal

Postby Tealc » Sun Oct 05, 2014 1:14 am

Still down.... do we know when it will be available again?

User avatar

Fermi
Site Admin
Posts: 225
Joined: Tue Jun 17, 2014 11:42 am

Re: Trouble Connecting To Portugal

Postby Fermi » Sun Oct 05, 2014 4:59 am

@Tealc,

Status went from timeout (exit node not reachable) to down (exit node reachable but no connection to VPN process isn't listening or not reachable [OpenVPN is DOWN on 94.46.8.229 UDP port 443]).
This could have several reasons: openvpn process needs to be (re)started by CS, port 443 blocked somewhere along the track, ... .

Best regards,

/Fermi

User avatar

cryptostorm_support
ForumHelper
Posts: 296
Joined: Sat Jan 26, 2013 4:31 am
Contact:

Re: Trouble Connecting To Portugal

Postby cryptostorm_support » Mon Oct 06, 2014 7:41 am

Just a quick update for you guys. We're still working with oneprovider on getting this all resolved, and currently remote login is being prevented due to an ssh bug. In talking with some of our server guys, it like we're going to be wiping and reinstalling. Sorry for the delay and inconvenience, and we're working to get brisa resurrected ASAP.
cryptostorm_support shared support team forum account
PLEASE DON'T SEND PRIVATE MESSAGES with support questions!
--> feel free to use any of our other contact channels, or post in the support forum
cryptostorm: structurally anonymous, token-based, unlimited ☂ bandwidth, opensource, darknet data security for everyone!
keybase.io validatorsonename.io validatorsPGP key @ MITnetwork statuscryptostorm github
support team bitmessage address: BM-2cTMH8K5JnjbfSALjZtSkRWCLfc3Tr8GBV
support team email: support@cryptostorm.is
live chat support: #cryptostorm

User avatar

marzametal
Posts: 505
Joined: Mon Aug 05, 2013 11:39 am

Re: Trouble Connecting To Portugal

Postby marzametal » Thu Oct 09, 2014 3:55 am

Seems to be connecting fine... has anyone noticed it takes longer than the other exit nodes? I noticed 2 loops while connecting, but the widget forced itself further...

User avatar

Tealc
ForumHelper
Posts: 283
Joined: Tue Jan 28, 2014 12:38 am

Re: Trouble Connecting To Portugal

Postby Tealc » Sat Oct 11, 2014 2:40 pm

Portugal node is down again :-(


EDIT: It's up again LOL

User avatar

vpnDarknet
Posts: 128
Joined: Thu Feb 27, 2014 2:42 pm
Contact:

Re: Trouble Connecting To Portugal

Postby vpnDarknet » Sun Oct 12, 2014 3:36 am

I've been cursing the Brisa cluster since I heard it was live, I've just not been able to get a connection.

I've copied, modded, an re-created .conf's with no luck
Tried the old faithful Network Manager, nil success
Re-loaded certificates, even though I know I have post heartbleed installed, nada

Today the though struck me; when I run the port alias I get no router traffic!
Firewall setting, updated iptables-vpn FTW! :roll:
Buy your tokens via vpnDark.net and cryptostorm cannot and does not know anything about users - no link between a token & purchase details
Unofficial Wiki cryptostorm access guide
Ways to talk to me

User avatar

Topic Author
parityboy
Site Admin
Posts: 1220
Joined: Wed Feb 05, 2014 3:47 am

Re: Trouble Connecting To Portugal

Postby parityboy » Wed Oct 15, 2014 10:06 pm

@thread

OK, so between last night and this morning my connection to Brisa lasted 10 hours. Today, it has lasted ~3 hours. This is what I get from the logs:

Code: Select all

Oct 15 17:07:00 vostok nm-openvpn[28086]: [server] Inactivity timeout (--ping-restart), restarting
Oct 15 17:07:00 vostok nm-openvpn[28086]: SIGUSR1[soft,ping-restart] received, process restarting
Oct 15 17:07:02 vostok nm-openvpn[28086]: WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Oct 15 17:07:02 vostok nm-openvpn[28086]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Oct 15 17:07:02 vostok nm-openvpn[28086]: UDPv4 link local: [undef]
Oct 15 17:07:02 vostok nm-openvpn[28086]: UDPv4 link remote: [AF_INET]94.46.8.229:443
Oct 15 17:07:04 vostok nm-openvpn[28086]: [server] Peer Connection Initiated with [AF_INET]94.46.8.229:443
Oct 15 17:07:06 vostok nm-openvpn[28086]: Preserving previous TUN/TAP instance: tun0
Oct 15 17:07:06 vostok nm-openvpn[28086]: /usr/lib/NetworkManager/nm-openvpn-service-openvpn-helper tun0 1500 1602 10.33.0.2 255.255.0.0 restart
Oct 15 17:07:06 vostok nm-openvpn[28086]: WARNING: Failed running command (--up/--down): external program exited with error status: 1
Oct 15 17:07:06 vostok nm-openvpn[28086]: Exiting due to fatal error


This is the config file use (exported from Network Manager - I'm not sure it exported everything):

Code: Select all

client
remote 94.46.8.229 443
ca /home/user/.openvpn/cryptostorm/Cryptostorm Certificate 02.crt
auth-user-pass
cipher AES-256-CBC
comp-lzo yes
mssfix
dev tun
proto udp
nobind
auth-nocache
script-security 2
persist-key
persist-tun
user nobody
group nobody

User avatar

Fermi
Site Admin
Posts: 225
Joined: Tue Jun 17, 2014 11:42 am

Re: Trouble Connecting To Portugal

Postby Fermi » Wed Oct 15, 2014 10:10 pm

Parityboy,

I think this is the moment where df updated the nodes:
viewtopic.php?t=6313&p=10035#p10035
(I experienced the same)

Regards,

/Fermi

User avatar

Topic Author
parityboy
Site Admin
Posts: 1220
Joined: Wed Feb 05, 2014 3:47 am

Re: Trouble Connecting To Portugal

Postby parityboy » Wed Oct 15, 2014 11:20 pm

@Fermi

Ahhh, that would make sense. I couldn't make out if the missing word in his post was "day" or "hour". :P


User avatar

cryptostorm_admin
ForumHelper
Posts: 74
Joined: Tue Jan 01, 2013 5:43 pm
Contact:

Re: Trouble Connecting To Portugal

Postby cryptostorm_admin » Mon Oct 20, 2014 4:51 am

parityboy wrote:Looks like Brisa is down again. Connection is timing out.


On it; more details in the Portuguese cluster 'teething pains' thread, for those curious.

Thank you,

~ cryptostorm_admin


Return to “member support & tech assistance”

Who is online

Users browsing this forum: No registered users and 11 guests

Login