Ξ welcome to cryptostorm's member forums ~ you don't have to be a cryptostorm member to post here Ξ
Ξ any OpenVPN configs found on the forum are likely outdated. For the latest, visit here or GitHub Ξ
Ξ If you're looking for tutorials/guides, check out the new https://cryptostorm.is/#section6 Ξ

Debian 9 - Connection fails every way i try :S

Post a reply

:
In an effort to prevent automatic submissions, we require that you enter the letters that are written in red.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek: :angel: :clap: :crazy: :eh: :lolno: :problem: :shh: :shifty: :sick: :silent: :think: :thumbdown: :thumbup: :wave: :wtf: :yawn:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

If you wish to attach one or more files enter the details below.

Expand view Topic review: Debian 9 - Connection fails every way i try :S

Re: Debian 9 - Connection fails every way i try :S

Post by confused2356 » Sun Dec 17, 2017 6:50 am

Luckily the integrated GNOME vpn client started working on it's own, strange!

Thanks for the assistance.

Re: Debian 9 - Connection fails every way i try :S

Post by parityboy » Thu Dec 14, 2017 6:23 am

@OP

I assume you are copy/pasting the hashed token into the shell? Can you confirm that the copy/paste is working correctly? I can't see how the username is null...you could try creating a text file with the username and password on separate, consecutive lines and using that to authenticate with.

Re: Debian 9 - Connection fails every way i try :S

Post by confused2356 » Mon Dec 11, 2017 6:57 pm

parityboy wrote:@OP

When you say "run it manually", are you supplying the username and password interactively or from a file? Can you specify the exact command line you are using to run it manually?

Thanks.


Not through a file, just after being prompted.

Code: Select all

$ sudo openvpn cstorm_linux-switzerland_udp.ovpn

Re: Debian 9 - Connection fails every way i try :S

Post by parityboy » Mon Dec 11, 2017 5:19 pm

@OP

When you say "run it manually", are you supplying the username and password interactively or from a file? Can you specify the exact command line you are using to run it manually?

Thanks.

Debian 9 - Connection fails every way i try :S

Post by confused2356 » Mon Dec 11, 2017 4:59 pm

I follow the instructions here:

https://cryptostorm.org/viewtopic.php?f=37&t=3978

I get:

'Connection Failed

Activation of network connection failed.'

When trying to run it manually i get:

'Enter Auth Username:
Enter Auth Password:
Mon Dec 11 19:57:28 2017 us=149350 ERROR: Auth username is empty
Mon Dec 11 19:57:28 2017 us=149389 Exiting due to fatal error'

I'm using the sha512 hash from here: https://cryptostorm.is/sha512.html I don't know what I'm doing wrong.

:crazy:

Top

Nothing to display.

Login